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Creating Accessible PDF Documents

Level

Intermediate - Advanced. Students are assumed to have experience with the different features
and menu options of Adobe® Acrobat®. Students will be working primarily with PDF document
accessibility preferences.

Summary and Objectives

The purpose of this lesson is to introduce the student to the use of Acrobat as a tool for making it
easier for vision- and motion-challenged users to access and manage information in PDF files. Acrobat
7.0 is compliant with U.S. Federal Code 508, which regulates document accessibility. Section 508
requires Federal departments and agencies that use electronic and information technology to ensure
that Federal employees and members of the public with disabilities have access to this documents in
an accessible format.

This lesson will specifically introduce: (1) Making exisitng PDF documents accessible, (2) Using Acrobat
to read a PDF file, (3) Setting Acrobat accessibility preferences, (4) Enhancing visibility of a PDF file, and
(5) Checking and analyzing the accessibility of PDF files.

Note: Screenshots used in this lesson are taken from both Mac and Windows computers. Although the
appearance may differ slightly, the features are identical on both platforms.

At the end of this lesson, students will be able to:

1. Perform a check of Accessibility.

2. Use the Read-Out-Loud feature.

3. Set Reading preferences.

4. Change visual aspects of a PDF document.
5

Reduce keyboard and mouse interaction.

> Lesson Twelve is designed to be taught in a single one-hour session. The student will
explore the preferences and options for different accessibility features and be able to make
PDF documents more accessible.
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Key Terms for Lesson Twelve

Screen Reader: An assistive technology application that enables visually impaired users to interact
with computer applications.

Unstructured PDF: All content is treated as a single unit without any hierarchies or relationships.
Unstructured PDF files retain the author’s text and paragraphs. All other formatting, including
formatting for basic text, tables, and lists, is lost.

Structured PDF: PDF files that have logical structure outlines that refer to the author’s contentin a
natural reading order. This structure tree appears on the Tags tab in the navigation pane and shows
elements nested at various levels.

Tagged PDF: Documents that have a logical structure plus additional information that permits reflow.
Tagged files recognize tables, formatted lists, and tables of contents. Tagged files also recognize
which content blocks belong to the different stories and contain text-formatting information such as
spacing between words.

Exercise One: Investigating PDF Accessibility Features

Accessibility features are tools and resources that make it easier for vision- and motion-challenged
users to access information and controls for Adobe PDF documents. Several features in Acrobat
address specific accessibility issues:

* Speech functionality, including support for utilities and devices that read visual elements,
controls, and text, and convert them into spoken language.

* Visibility adjustments to make text and graphics easier to view for people with a limited range
of vision.

* Navigation through documents using auto-scroll, to reduce required keyboard and actions.

¢ Keyboard alternatives to mouse actions.

¢ Options for creating Adobe PDF files that make documents more reliably accessible.

About Reading Preferences

The Reading Preferences panel contains a list of the different options that can be set for a particular
PDF document. To Access these preferences, choose Edit > Preferences and click on the Reading
preference in the left-hand pane.

You can use the Reading preferences to change the volume, speed, and order in which documents are

read out loud. If you experience difficulties reading a document with a screen reader, changing the
reading order preference options can sometimes help.
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To set your Reading preferences, do this:
1. Open the Brochure.pdf from the Acrobat Curriculum
Guide Resources folder.

2. When the document opens, Choose Edit >
Preferences and select Reading.

3. For Reading Order Options, select a Reading Order
option, and choose whether to override the reading
order in tagged documents.

4. For Screen Reader Options, leave the settings
unchanged.

5. For Read Out Loud Options, select the settings you
want for Volume, Voice, Pitch, and Words Per Minute.

6. Click OK.

Exercise Two: Checking Accessibility
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For this activity, you will use the “Section 508 Facts” brochure located in the Acrobat Curriculum Guide
Resources folder. You will first check its accessibility and then use the Read-Out-Loud feature. Though
not an actual screen reader, the Read-Out-Loud feature makes it easy for PDF files to be read by your
computer as long as the information in the document is tagged. Tagging information in a PDF file
allows screen readers to infer a logical sequence for reading. You can read aloud as much of an Adobe
PDF document as you need: a page, a section, or the entire document.

1. Navigate to Page 1 of the Brochure.pdf
2. Choose View > Read Out Loud > Read This Page Only.

Notice that the Page does not read aloud. Not all PDF files can be read until some additional steps are

performed. You will now check the document’s accessibility.
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Checking Accessibility
To check the Accessibility of a PDF file:

3. Choose Advanced > Accessibility > Quick

Check and click OK

The Results message is displayed:

Acces

sibility Quick Check

Results

Accessibility Quick Check is complet

s

This document has logical structure but it is not a Tagged PDF. Some accessibility

information may be missing.

This document cannot be read until tags are added to the document. These tags tell the screen reader
and other assistive technology devices how to treat the text blocks, paragraphs, etc.

4. Choose Advanced > Accessibility > Add Tags To

Document.

Acrobat will evaluate the document and display a report. The
report pane provides a summary and a list of “low confidence”
items. These are items that a screen reader would have

trouble reading in a logical sequence.

5. Click on the links to display the problem text.

6. Inthe Report How-To section, click on the link “To fix this
structure... open the TouchUp reading order tool”.

7. Click the Show Order panel to display the document’s tag

order.

8. Click the Order Tab and click on Page 2 to reveal its

reading order.

The tagged items on Page 2 are displayed. The How-to panel
gives further instructions on adjusting the list order.

(&) TouchUp Reading Order

Draw a rectangle around the content
then click one of the buttons below:

@ Show page content order
!25 Show table cells

E Show tables and figures

/_ Clear Page Structure... \ ’

W

Help Close
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Performing a Full Check of Accessibility

You can have Acrobat perform a full check and give you a report based on the parameters you set.
This can be a time-consuming task on large documents. Pressing the Escape button can stop the
process.

1. Choose Advanced > Accessibility > Full Check...

The following window opens.

Accessibility Full Check

Report and Comment Options

E Create Accessibility Report
Eoannn)
Folder: TiBookHD:Users:sadler:Documents:
@ Include repair hints in Accessibility Report

__ Create comments in document

Page Range
@ All pages in document
t Only those pages selected in Fages panel

=
. Pages from 2 o

Checking Options

@ Alternative descriptions are provided

E Text language is specified

@ Reliable character enceding is provided

@ All content is contained in the document structure
@ All form fields have descriptions

@ List and table structure is correct

E Tab order is consistent with the structure order

/ Help \ ’ Cancel _\f'smﬂ'checking%

2. Click “Start Checking”.

A few moments later, you will be presented with a summary and a link for learning how to set a
language specification. Follow the How-To instructions for correcting this.

Summary

The checker found problems which may prevent the
document from being fully accessible.

e All of the text in this document lacks a language
specification. (How to Add Languase)
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Exercise Three: Improving the Accessibility Experience on Your Computer

Reading Out Loud
Your PDF file is now ready for the Read-Out-Loud feature of Adobe Acrobat.

3. Choose View > Read Out Loud > Read This Page Only.

Your document will now begin to read in the proper reading order. It is now accessible by everyone!

Enhancing Visibility

You can set various options to make it easier to see and read Adobe PDF documents on screen. You
can:

* Magnify the displayed document using the Viewing toolbar, the Zoom options on the status
bar, or the commands on the View menu.

* Enlarge or reduce the font size of the bookmark text with the Options menu on the Bookmarks
tab.w

* Set the background color of pages and the color of the text in the Preferences dialog box.

* Replace document colors.

To adjust the Accessibility options, you use the Accessibility Setup Assistant.

4. Choose Advanced > Accessibility > Setup Assistant.

You can skip the assistant or step through the different panels and try out some different settings.

>»Be sure to use colors that improve visibility. These color changes will not print but be
viewable on screen. These changes will affect all the PDF documents on your computer.

Accessibility Setup Assistant

This is the Accessibility Setup Assistant. In the next faw panels you will be guided in
setting up the options that affect how Acrobat displays documents and interacts with
assistive technology.

Each panel will allow you to go back to a prior panel or cancel the process. Your
settings will not be recorded until you select the 'Done’ button on the last panel.

First, we would like to know what assistive technology you are using. This will let us
tailor the following options.

=
./ Set options for screen readers

—~

./ Set options for screen magnifiers

@ Set all accessibility options

'_ Use recommended settings and skip setup \

L

/_ Cancel f Next 3
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Minimizing Mouse and Keyboard Usage

In order to reduce the amount of clicking and keyboard use for a PDF file, Acrobat allows you to set
some additional options that will reduce the physical and visual effort required by the user when
working with the accessible PDF document.

Using Reflow

Once a PDF file has been tagged properly, its contents can be re-flowed to fit different screen sizes
and document areas. This will also enable reduce background colors and make automatic scrolling
more effective.

To reflow your Brochure.pdf, do this:

1. Click on the single page or continuous page icon at the The Access Board
bottom of the document window. >

a federal agency commtitted to accessible design |
2. Choose View > Reflow. B
(If it is greyed out, you have not added the tags from the
previous activity). R

The document will change its appearance.

3. Drag the lower-right corner of the document window to resize it. Notice that the content reflows
to fit the window size. This is because the document contains the proper tags needed for
accessibility.

@

e " brochure.pdf

Nl

Important Dates

August 7, 1998

President Clinton signed the Workforce Investment Act,
including the Rehabilitation Act Amendments with an expanded
and strengthened Section 508.

March 31, 2000
The Access Board issued a Notice of Proposed Rulemaking
(NPRM), setting forth the proposed standards.

T |

December 21, 2000
Final Section 508 standards were published in the Federal
Register.

—

January 22, 2001

The Federal Acquisition Regulation (FAR) was proposed to be
amended by adding the Section 508 standards to procurement
regulations.

[ Pages | Layers | Signatures Y Bookmarks

April 25, 2001
The FAR Final Rule was published in the Federal Register.

Ef Comments

June 21, 2001
Enforcement of the Section 508 standards begins. f
A 573 x19.42in
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Scrolling Automatically

The automatic scrolling feature makes it easier to scan through a long document. You can scroll
through pages without using keystrokes or mouse actions. To scroll automatically through a
document, do this:

Choose View > Automatically Scroll.

* To change the scrolling speed, press a number key where 9 is the fastest and 0 is the slowest
or press the Up or Down arrow keys.

* Toreverse the direction of the scrolling, press the hyphen or minus sign key.

* Tojump to the next or previous page, press the Left or Right arrow keys.

* To stop automatic scrolling, press ESC or choose View > Automatically Scroll again.

Using Keyboard Shortcuts

Using keyboard shortcuts for menu commands and navigation, you can control many navigation
functions from the keyboard instead of the mouse. In Windows, some of the keyboard shortcuts used
to navigate in Acrobat may differ from those used in other Windows applications.

>»Keyboard Shortcuts are very powerful for all types of users. Some of the shortcuts vary for
each platform and version of the operating system. More information can be found in the
Acrobat Help file.

Macintosh OSX users can navigate and interact within the Acrobat work area and Adobe PDF
documents by setting up the appropriate system-level preferences.

To set up full keyboard access on a Macintosh computer, do this:

On the Apple menu, choose System Preferences, and select Keyboard.

In the Keyboard Preferences dialog box, select the Full Keyboard Access tab.
Select the Turn On Full Keyboard Access and Any Control.

Quit System Preferences.

HwnN =

Windows users can use the keyboard to control Acrobat within Microsoft® Internet Explorer.

* Pressing the Tab key shifts the focus from the browser to the Acrobat document and
application. The navigation and command keystrokes will function normally.
*  Pressing Ctrl + Tab shifts the focus from the document back to Internet Explorer.

Summary

With proper inspection and planning, Adobe PDF documents can be re-purposed with a minimum of
effort to provide users of all kinds with the ability to view PDF files in a number of different ways, from
a PDA screen, to assistive screen reading devices.
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Activities:
* Investigate other information about Section 508 on the Web using Google.com for searching.
* Have students check and convert existing PDF files such as school information for accessibility.

* Have students experiment with different screen enhancements and reading preferences for a
particular document and have them present their different versions to the class.

* Generate Accessibility reports on PDF documents from a variety of sources and discuss the
different findings and hints for improving accessibility.

* Convert Web pages to PDF using the techniques learned earlier. Notice that since Web pages are
already tagged, many of them are already defined for accessibility.

* If students have access to PDAs, have them load Accessible PDF files to their devices and report on
the appearance of their document compared to the original.

Additional Adobe Resources on the Web

Visit the Adobe in Education Web site at www.adobe.com/education for additional resources

* Instructional resources

e Product information

* Training opportunities

* Solutions for K-12 and higher education

Important note: The Adobe Acrobat Curriculum Guide may be used only by certified K-12 and university educators and may be used only in
the classroom. Distribution of the Guide outside of the educator’s classroom or commercial use of the content of the Guide is prohibited. If
you are interested in using the Adobe Acrobat Curriculum Guide in any other way, please contact the author, Steve Adler, at his Web site:
www.guidedsystems.com.

Adobe, the Adobe logo, Acrobat, Distiller, lllustrator, Photoshop, and PostScript are either registered trademarks or trademarks of Adobe
Systems Incorporated in the United States and/or other countries. Mac is a trademarks of Apple Computer, Inc., registered in the United
States and other countries. Windows is either a registered trademark or trademark of Microsoft Corporation in the United States and/or other
countries. All other trademarks are the property of their respective owners.

© 2005 Steve Adler. All rights reserved.

Adobe Acrobat Curriculum Guide 9



